プロトコル Cisco

PPPoEとは?Ciscoルータによる拠点間VPNの設定方法

投稿日:2015年11月1日 更新日:

 

今回は、ciscoルータのPPPoEのコンフィグについて
ですが、まずはPPPoEってそもそもなにというところから。

PPPoEというのは、PPP over Ethernetの略で、
深いところは複雑なので、実は僕もよくわかってなくて、

 

ようするに、PPPという一対一で認証・認可を与えるプロトコルを
Ethernet上で使用するものだぐらいの理解です…。

 

それよりもちゃんと覚えておきたいのは、
どの場面で使用するかということです。
それは通信プロバイダのネットワークにつなげるときです。
(フレッツなどNTT網と接続する際)

 

つまり、インターネットへ抜けるときや、
プロバイダのVPN契約などをしていて、拠点先などと通信をする必要があるときに使用します。

 

実は、自宅のインターネットを閲覧するためにもこの技術が使われています。

 

通常、自宅の環境ではPCがグローバルIPアドレスを取得して、
インターネットを使用しますので、PCにPPPoEの設定をします。

特に、アパート・マンションにプロバイダの契約をして、
インターネットを使用したことがあれば、設定をしたことがあると思います。

 

しかし、企業などのネットワークであれば、
企業内にローカルのネットワークを作りますので、
ローカルネットワークとインターネットの間にルータを置きます。

そのルータにグローバルIPアドレスを割り当てて、
(PPPoEでプロバイダからグローバルIPを取得して)
企業内の端末はインターネットを利用します。

 

また、ルータにアクセスリストを設定すれば、
インターネットからはルータのIPアドレスしか見えないということになりますので、
セキュリティの面でも向上します。

 

普通はさらにファイアーウォールを置いて制御しますが…。

 

ではやっと本題ですが、
ciscoルータのPPPoEのサンプルコンフィグを記載します。

想定ネットワーク構成。
NTTのサービス「フレッツ・VPNワイド」を利用した拠点間の接続を想定しています。

 

PPPoE拠点間VPN接続

 

interface Loopback0
ip address 192168.1.1 255.255.255.255 ///プロバイダから割り当てられた固定のグローバルIPアドレス

interface FastEthernet0/0 ///WAN側インターフェース
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
interface FastEthernet0/1 ///LAN側インターフェース
ip address 192.168.100.1 255.255.255.0
ip tcp adjust-mss 1414
duplex auto
speed auto

interface Dialer1 ///PPPoEに必要な仮想インターフェース
ip unnumbered Loopback0 ///interface Loopback0 のIPアドレスを指定
ip mtu 1454
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname (user1) ///プロバイダ契約時に設定
ppp chap password (password) ///プロバイダ契約時に設定
ip route 192.168.1.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

dialer-list 1 protocol ip permit

 

MTUサイズとMSSサイズはプロバイダのホームページなどで確認してください。

一般的にはMTUサイズ:1454、MSS:1414にしますが、
企業の通信が不安定になって、トラブルシュートしたらMSSサイズが原因だったことあります。

 

今回、拠点とのVPN接続を想定して作成しましたが、
インターネットルータとしてPPPoEの設定をしたい場合は以下のページをご覧ください。

→ https://www.network-engineer.info/cisco_config/インターネットルータ設定方法/

 







-プロトコル, Cisco
-, ,

執筆者:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA


このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください

関連記事

Cisco ACS ver4.xとver5.xの違いについて

  ACSの勉強と構築する機会があったので、 今回はACS ver4.xとver5.xの違いを説明したいと思います。 ver4とver5の大きな違いは、 認証モデルとレプリケーションの違いで …

ARPとはなにか。~IPアドレスからMACアドレスを導くプロトコル~

  では、今回は、Layer2とLayer3をつなげる「ARP」についてです。 いきなり「Layer」という単語が出てきましたが大丈夫でしょうか。いわゆる「OSI参照モデル」のアレです。La …

Ciscoルータ、L3スイッチ VRFの設定方法

  今回は、Ciscoルータ、L3スイッチによるVRFの設定についてです。 VRFとはL3の仮想化技術です。(VLANはL2の仮想化技術) ルーティングテーブルを論理的に分割することができま …

UDPとはなにか。~とにかく早くデータを送り届けるプロトコル~

今回は、 とにかく早くデータを送り届けるプロトコル「UDP」についてです。   「UDP」は「User Datagram Protocol」の略で、「TCP」と同様トランスポート層(Laye …

Cisco Catalyst 9200 シリーズについて

Catalyst 9200 シリーズの備忘録となります。詳細はCiscoサイトをご確認ください。 → https://www.cisco.com/c/ja_jp/products/switches/c …

ナナシ

ナナシ(30前後の男)



プロフィールはこちら