Cisco

Ciscoルータ、L3スイッチ VRFの設定方法

投稿日:

 

今回は、Ciscoルータ、L3スイッチによるVRFの設定についてです。

VRFとはL3の仮想化技術です。(VLANはL2の仮想化技術)
ルーティングテーブルを論理的に分割することができます。

 

以下のように通常では2セットの機器を用いる必要がある2つのネットワークに対して、
1セットの機器だけで対応可能となるので、非常にコスパの良い技術です。

VRF図

 

●VRFを作成し、RDを規定する。

RDとは、「Route Distingusher(ルート識別子)」の略で、VRF間通信を行う際に使用します。

VRFで通信を完全に分ける際は、RDの設定がなくても可能ですが、いろんなサイトや構築経験からしても、追加しておくのがきれいな形だと思います。

ip vrf [vrf名]
rd 100:1 /// rd XX:YY と表すとXXが自律システム番号(AS番号)で、YYが任意番号

ip vrf [vrf名]
rd 100:2

 

●interface VLAN を作成する際は、VRFの定義が必要になります。
(物理インターフェースをルーテッドポートとして使う場合も同様)

interface Vlan1
ip vrf forwarding vrf1
ip address [IP Address] [Mask]

interface Vlan10
ip vrf forwarding vrf2
ip address [IP Address] [Mask]

 

●ルーティングを設定する際も当然必要です。

ip route vrf vrf1 0.0.0.0 0.0.0.0 xx.xx.xx.xx

router ospf 1 vrf vrf2
network [] [] area 0

 

●その他の設定です。

snmp-server community public RO
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server host xx.xx.xx.xx vrf vrf1 public

logging host xx.xx.xx.xx vrf vrf1

ntp server vrf vrf1 xx.xx.xx.xx

 

●検証コマンドにVRFの指定が必要になります。

telnet xx.xx.xx.xx /vrf vrf1
ping vrf vrf1 xx.xx.xx.xx
traceroute vrf vrf1 xx.xx.xx.xx

 

●showコマンドについてもVRF指定が必要になります。

・show ip route vrf vrf1
・show ip arp vrf vrf1

L3に関係してくるものは、
すべてVRFの指定が必要になるということです。

 







-Cisco
-, ,

執筆者:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA


このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください

関連記事

Cisco無線LANのトラブルシューティング

無線を導入していると 「通信が遅い」や「無線接続が途切れる」といった トラブルが発生することが少なからず発生します。 既存環境の調査として、調査込みのサイトサーベイを依頼されたこともありますが、 一般 …

Cisco Catalyst6500/4500 VSSの設定方法

VSS(Virtual Switching System)とはCatalyst6500や4500で使用する技術で、 2台の機器を1代台の機器に見せる技術です。 Catalyst3750などで使用するS …

Cisco WLCのバックアップ・リストア方法

あらかじめ作業用端末PC上に3CDaemonなどのフリーのTFTPソフトを起動します。 知らなかったんですが、最近のバージョンからはHTTPでダウンロード・アップロードが可能になってました。 Cont …

Cisco ACS ver4.xとver5.xの違いについて

  ACSの勉強と構築する機会があったので、 今回はACS ver4.xとver5.xの違いを説明したいと思います。 ver4とver5の大きな違いは、 認証モデルとレプリケーションの違いで …

Cisco GREoverIPSecの設定方法

  GREoverIPSecについての説明は他サイトをご覧ください。 「GREoverIPSec」とgoogle検索すると詳しく解説しているものが 複数出てきます。 ここでは、GREover …

ナナシ

ナナシ(30前後の男)



プロフィールはこちら