Cisco

CiscoルータでPPPoEサーバを設定する方法(複数拠点接続)

投稿日:2014年3月15日 更新日:

EthernetのLAN環境から、企業に拠点があって通信業者のWAN網を使う場合、
または、インターネットに接続する際などに、「PPPoE」という技術を使います。

PPPoEとは、PPP over Ethernetの略でEthernet上でPPPフレームをやりとりできる。

また、PPPとは、Point to Point Protocolの略で、ポイントツーポイントで接続し、認証やIPアドレスの割り当てなどを行うプロトコルです。

このPPPoEの検証を社内など通信事業者の回線の引いていない場所で行う場合、CiscoルータでPPPoEサーバをたてて、実際に拠点間でうまく通信ができるかなどのように検証します。

今回は、CiscoルータでPPPoEサーバをたてるためのコンフィグを備忘録的に書いておこうと思います。

以下、ネットワークを想定しています。

PPPoE

以下、コンフィグです。

**********************************************************************

hostname PPPoE-Server

vlan 1-3

username 〈拠点ルータ①username〉 password 〈拠点ルータ①password〉
username 〈拠点ルータ②username〉 password 〈拠点ルータ②password〉
username 〈拠点ルータ③username〉 password 〈拠点ルータ③password〉

bba-group pppoe pppoe01
virtual-template 1
!
bba-group pppoe pppoe02
virtual-template 2
!
bba-group pppoe pppoe03
virtual-template 3

interface Loopback1
ip address 10.10.1.1. 255.255.255.255  ///ここのIPはなんでもOK///
!
interface Loopback2
ip address 10.10.1.2 255.255.255.255
!
interface Loopback3
ip address 10.10.1.3 255.255.255.255

interface GigabitEthernet1
switchport access vlan 1
!
interface GigabitEthernet2
switchport access vlan 2
!
interface GigabitEthernet3
switchport access vlan 3

!
!
interface Virtual-Template1
mtu 1454
ip unnumbered Loopback1
peer default ip address pool pool01  ///任意のpool名///
ppp authentication pap chap
!
interface Virtual-Template2
mtu 1454
ip unnumbered Loopback2
peer default ip address pool pool02
ppp authentication pap chap
!
!
interface Virtual-Template3
mtu 1454
ip unnumbered Loopback3
peer default ip address pool pool03
ppp authentication pap chap
!

!
!
interface Vlan1
no ip address
pppoe enable group pppoe01
!
interface Vlan2
no ip address
pppoe enable group pppoe02
!
interface Vlan3
no ip address
pppoe enable group pppoe03
!
ip local pool pool01 〈拠点ルータ①払い出されるIP〉 ///interface Virtual-Template1で設定したpool名と対応///
ip local pool pool02 〈拠点ルータ②払い出されるIP〉
ip local pool pool03 〈拠点ルータ③払い出されるIP〉

**********************************************************************

拠点がもっと増える場合は、同じ感じで増やしていただけでば、OKかなと。







-Cisco
-, , ,

執筆者:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA


このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください

関連記事

Ciscoインターネットルータ設定方法(コンフィグ),アクセスリストの設定

今回は、ciscoルータ(Cisco 892J想定)をインターネットルータとして使う際の サンプルコンフィグを記載します。(PPPoEの設定がメインです。)   その前にPPPoEとは →  …

Ciscoルータ、L3スイッチ VRFの設定方法

  今回は、Ciscoルータ、L3スイッチによるVRFの設定についてです。 VRFとはL3の仮想化技術です。(VLANはL2の仮想化技術) ルーティングテーブルを論理的に分割することができま …

Cisco Catalyst6500/4500 VSSの設定方法

VSS(Virtual Switching System)とはCatalyst6500や4500で使用する技術で、 2台の機器を1代台の機器に見せる技術です。 Catalyst3750などで使用するS …

Cisco WLC5520 シャットダウン方法

最初に記載しておきますが、WLC5520では、電源ケーブルをいきなり抜いてもOKです。 前型番のWLC5508では、裏面にスイッチがあったのですが、WLC5520ではなくなっています。shutdown …

Cisco WLC APセットアップ・GUI初期設定方法

APの初期セットアップ、APグループへの登録、FlexConnectの設定などについて記載します。 Contents1 APのセットアップ手順2 APのGUI初期設定手順2.1 AP のIPアドレス、 …

ナナシ

ナナシ(30前後の男)



プロフィールはこちら