Cisco

Cisco Catalyst6500/4500 VSSの設定方法

投稿日:2016年1月9日 更新日:

VSS(Virtual Switching System)とはCatalyst6500や4500で使用する技術で、
2台の機器を1代台の機器に見せる技術です。

Catalyst3750などで使用するSTACKの技術で、
Catalyst6500/4500に適応するものがVSSだと思ってもらえればいいです。
コンフィグも合体します。

VSSは2台の筐体間を結ぶVSL(Virtual Switch Link)により実現します。
VSLは10Gの光ケーブル(10GBASE-SR)で接続して、EtherChannelを組みます。(最大8組みまで可能)

VSSの設定方法

————-以下、設定コンフィグです。————-

switch virtual domain 100
switch mode virtual
switch 1 priority 110
!

redundancy
main-cpu
auto-sync running-config
mode sso

interface Port-channel100
no switchport
no ip address
no platform qos channel-consistency
switch virtual link 1
!
interface Port-channel200
no switchport
no ip address
no platform qos channel-consistency
switch virtual link 2

interface TenGigabitEthernet1/5/5
no switchport
no ip address
no cdp enable
channel-group 100 mode on

interface TenGigabitEthernet2/5/5
no switchport
no ip address
no cdp enable
channel-group 200 mode on

router ospf 1
nsf

—————————————————-

これでVSSは組めました。確認コマンドは「show switch virtual」です。
Active機が何らかの影響で停止した場合、
Standby機がActive機へフェールオーバーします。

ちなみに、Active/Standbyという呼び名ではありますが、
Standby機は通信を行っていないかというとそうではなく、
Active-Activeで動作しています。(Stackのように)

デュアル アクティブ検知について

ただし、上記設定だけでは、
もし、VSLが切れた場合、両機ともが相手に何らかの影響があり、
通信が途絶えたと判断して、両方Active機になってしまいます。

この現象を「デュアル アクティブ」と呼びます。
デュアル アクティブになると、同一IPアドレスがネットワーク上に2つ存在することになり、
非常に不安定なネットワークになってしまいます。

そのため、デュアル アクティブを検知する設定を投入する必要があります。

デュアル アクティブ検知後の動作としては、
どちらか1機のVSLインターフェース以外のすべてのインターフェースをシャットダウンします。
VSLが復旧するとrloadし、Standby機としてアップします。

デュアル アクティブ検知の設定としては3種類あります。

・PAgP
・BFD(IP Bidirectional Forwarding Detection)
・fast-hello

ciscoのサイトには詳しく載っていますが、
ciscoのサイトは激しく見にくいため、
ここで簡潔に載せておきます。

まずどれを選択するかというと、
BFDは使わないと思います。
PAgPか、fast-helloでしょう。

PAgPはEtherchannelで使用するプロトコルです。
よって、6500の配下にciscoスイッチを置いて、
PAgPを使ったEtherchannelを使用することが必須です。

BFDとfast-helloはVSLとは別に2台のシャーシ間で直接接続する必要があります。
ゆえに、ポートに余裕がない場合は厳しいでしょう。

処理の速さとしては、
BFD < PAgP < fast-hello です。

だから、BFDは使いません。
それを使うぐらいだったら、fast-helloにします。

————-PAgPのコンフィグが以下です。————-

interface port-channel 10
shutdown

switch virtual domain 100
dual-active detection pagp
dual-active detection pagp trust channel-group 10

interface port-channel 10
no shutdown

————-fast-helloのコンフィグが以下です。————-

switch virtual domain 100
dual-active detection fast-hello

interface fastethernet 1/1/10
no switchport
dual-active fast-hello
no shutdown

—————————————————————–

以上です。ご参考になれば幸いです。







-Cisco
-, , ,

執筆者:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA


このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください

関連記事

Cisco CatalystスイッチとVM vSwitchのリンクアグリゲーション構成について

仮想基盤構築にあたって、 ネットワークスイッチとESXiとの接続は、ネットワークエンジニアとサーバエンジニアの境目になるところであって、認識のずれによって、トラブルになりやすいところとなります。 ネッ …

Cisco無線LANのトラブルシューティング

無線を導入していると 「通信が遅い」や「無線接続が途切れる」といった トラブルが発生することが少なからず発生します。 既存環境の調査として、調査込みのサイトサーベイを依頼されたこともありますが、 一般 …

Cisco の各種サイト一覧

Cisco機器を扱う上で利用するようなサイト一覧のメモとして   【cisco 構成作成】 ・CCW(Cisco Commerce Workspace) https://apps.cisco.com/ …

Cisco WLCの初期化方法(Factory default)

WLCを工場出荷時状態に戻す設定方法を記載します。 Contents1 GUIで初期化2 CLIで初期化 GUIで初期化 1.COMMANDS タブに移動します。 2. Reset to Factor …

Ciscoルータ・スイッチをDHCPサーバとして設定する方法

  今回は、ciscoルータをDHCPサーバにするための設定方法を解説します。   実は、ルータだけでなく、L3機能を有していればDHCPサーバとして動かすことが可能なので、L3ス …

ナナシ

ナナシ(30前後の男)



プロフィールはこちら